Discussion:
Corrupt Credential Store in Cloud Control, 13.2
(too old to reply)
MacGregor, Ian A.
2018-09-21 18:55:34 UTC
Permalink
I have had a ticket open with Oracle support for over two months on this problem. They have been working diligently, and have made several suggestions, but none have worked so far.


Here's how the corruption happened.


I was applying a patch which proceeded as expected until it tried to log into the database. It then informed me not that the password was wrong, but that it didn't meet standards because it was lacking one of the three or four special characters required by the standard. I was taken aback that the patching software enforces a standard not enforced by the utility used to change passwords, emctl.


Fine I thought, I'll just rollback, the patch change the password and then restart the patch apply. The patch could not be rolled back. I got an error saying something along the lines that a patch was in progress. So I then used emctl to change the password, making sure it had one of the mandatory special characters. I then instructed the patch to continue. It did, logging into the repository database without a problem, and completing normally.


After the patch finished I ran


emctl stop oms -all

followed by emctl start oms.



Everything is fine until it gets to starting the JVMD engine. This appears to be where the corruption is as it fails to start. I think because I didn't know to run


emctl extended oms jvmd stop –all


nor know to run


emctl stop oms -bip_only


But it looks like JVMD is the problem.


Because the JVMD extension to the OMS won't come up, neither will the OMS.

However the servers and databases are being monitored and messages are being sent when thresholds are crossed. I cannot however log into it.


So is there a way of fixing the credential store. I tried resetting the sysman password, but its complains about the credential store being corrupted due to missing information. One of the thing support had me do was to log into the WLS console and check on things there. All the right boxes were checked.



Any ideas on how to proceed?






Ian A. MacGregor
SLAC National Accelerator Laboratory
Computing Division
To offer the best IT service at the lab and be the IT provider of choice.
Loading...